PythonTip >> 博文 >> chinaunix

windows下python的包管理器pip安装

zihua 2014-01-13 18:01:35 点击: 778 | 收藏


如果是真正做python开发,要用到第三方包,python的版本就必须是2.7.x,我用到的twisted和ReportLab都不支持3.0以上的版本。

http://www.pip-installer.org/en/latest/installing.html#python-os-support

主要就是两步,安装setuptools,安装pip,先下载两个文件 ez_setup.py和get-pip.py这两个文件,在cmd下运行,

python ez_setup.py

python get-pip.py

安装就成功了。文件下载链接见给出链接

如何使用呢,首先添加c:\python27和c:\python27\scripts到系统PATH中

接下来就可以在cmd中注意是windows的cmd中

直接pip install Reportlab了。

安装还除了点事情就是没有找到c编译器,提示错误vcvarsall.bat找不到

网上说重新安装vc2008 express就好了,我已经有vs2010了,但是不行,后来google找到

只要设置
SET VS90COMNTOOLS=%VS100COMNTOOLS%
这句就行了。估计pip只认
VS90COMNTOOLS
这个环境变量,哈哈哈好傻。

原文链接:http://blog.chinaunix.net/uid-29146624-id-3888676.html

作者:zihua | 分类: chinaunix | 标签: python | 阅读: 778 | 发布于: 2014-01-13 18时 |
上一篇:python点滴
下一篇: python单元测试初探