PythonTip >> 博文 >> Uliweb

Uliweb 更新:支持 Dotcloud 和 i18n 的改进

zihua 2013-09-26 01:09:06 点击: 939 | 收藏


昨天想试一试如何在dotcloud上部署uliweb,不过因为我是在windows下测试,如果执行报错。后来查了一下,结果发现目前dotcloud只支持linux,因为涉及到象rsync,ssh之类的命令,所以我只能今天再虚拟机上试了。还没有时间进行。不过对uliweb进行了一些改造,以便方便在dotcloud上的部署。

目前向uliweb增加了一个support命令,它目前可以支持GAE和dotcloud。原来uliweb在创建完project之后,会生成如app.yaml和gae_handler.py的文件。不过增加了support命令之后,这两个文件就不自动生成了。如果你需要,可以执行:

uliweb support gae

来获得。注意,运行目录是在你的项目目录下。

如果想部署到dotcloud上,则可以运行:

uliweb support dotcloud

它将拷贝wsgi.py和requirements.txt。wsgi.py其实和wsgi_handler.py是一样的,requirements.txt目前只有一行,目的是安装uliweb。不过还没有试验,有了进一步结果我会再进行报告。

另一个修改就是i18n的支持,更详细的我会写一份文档,回头放到uliweb-doc项目中。

目前i18n有以下的配置项:

[I18N]
LANGUAGE_COOKIE_NAME = 'uliweb_language'
LANGUAGE_CODE = 'en'
LOCALE_DIRS = []
SUPPORT_LANGUAGES = []

第一项你不用管它,它是用来从cookie中获取语言信息的。第二个是用来控制缺省的网站语言的,这是当无法自动获取前端想要的语言时才会最后起作用。LOCAL_DIRS是用来放置翻译文件的。在uliweb中,它只是用来获得翻译文件目录的其中一个地方,uliweb还会从项目目录 ,app目录,uliweb本身的目录下,以及这个目录下获得翻译文件。目前用在plugs下。在plugs下有一个locale目录,用来存放plugs中i18n的翻译文件。SUPPORT_LANGUAGES表示网站所支持的语言种类。除原本开发所使用的语言外,如果浏览器自动希望某种语言,并且这种语言在SUPPORT_LANGUAGES所支持的范围之内时,才会生效。

原文链接:http://www.simple-is-better.com/news/326

作者:zihua | 分类: Uliweb | 标签: i18n dotcloud | 阅读: 939 | 发布于: 2013-09-26 01时 |